Jump to content
House Price Crash Forum

Archived

This topic is now archived and is closed to further replies.

Frank Hovis

Hotmail Running Unbelievably Slowly

Recommended Posts

It's been like this for a few days now. I've had problems with it before but they've never lasted long.

Sign-in usually takes three goes, first two go to a blank screen and stops.

Sending anything takes forever. Usually it stops the first time after trying to send for ages, then I need to press send again.

Just awful and I'm glad I'm not reliant on it.

On Firefox with Noscript and Adblocker.

Share this post


Link to post
Share on other sites

NSA servers trawling through all the emails?

I always cc GCHQ in on every email I send, just in case they miss one.

Share this post


Link to post
Share on other sites

It's sucked ever since they started the migration to outlook.com here - sooner or later will move over to gmail, just hate the thought of updating all my accounts!

Share this post


Link to post
Share on other sites

It's been like this for a few days now. I've had problems with it before but they've never lasted long.

Sign-in usually takes three goes, first two go to a blank screen and stops.

Sending anything takes forever. Usually it stops the first time after trying to send for ages, then I need to press send again.

Just awful and I'm glad I'm not reliant on it.

On Firefox with Noscript and Adblocker.

Yes... Very annoying. As a loyal customer since the mid 90's I hope they sort it out soon. Hopefully just some glitches with the Outlook move or something

Share this post


Link to post
Share on other sites

Good news in that it's clearly not just my computer :)

Ta for the replies.

If everyone did that :lol:

Share this post


Link to post
Share on other sites

Didn't Hotmail originally run on FreeBSD?

Maybe now its running on Windows Server 12, and the admins haven't enough tablets to access the Metro screen.

Couldn't log into Outlook.com earlier which I think is the same thing.

Tried the latest eval of Windows server yesterday. Its quite baffling in its complexity,

Share this post


Link to post
Share on other sites

It must be that Prism thing.

It has been awful for days then I post this thread and it's working like a dream!

It just goes to show.

Share this post


Link to post
Share on other sites

It must be that Prism thing.

It has been awful for days then I post this thread and it's working like a dream!

It just goes to show.

Thanks Frank. Mine is fixed too. They must have been doing an upgrade.

Share this post


Link to post
Share on other sites
Guest unfunded_liability

Outlook's flaky again this morning. It's been problematic since the forced switchover from Hotmail earlier this year - intermittent problems with login, changing folders, attachments, writing emails. The standard Microsoft Support response is "clear your cache" :D A bit like Win8 I don't think it has many fans.

Share this post


Link to post
Share on other sites

Outlook's flaky again this morning. It's been problematic since the forced switchover from Hotmail earlier this year - intermittent problems with login, changing folders, attachments, writing emails. The standard Microsoft Support response is "clear your cache" :D A bit like Win8 I don't think it has many fans.

Yup, back to taking three times to sign in.

Share this post


Link to post
Share on other sites

Its getting worse and worse everyday :-(

I've been with Hotmail probably about 15 years and don't want to move but its getting unusable now.

Hotmail, to me, seemed like one of Microsofts best web products and now they've killed it

Share this post


Link to post
Share on other sites

Same issues here. It's annoying as my business email address is a hotmail one and I haven't been able to get in for 2 days. It logs me in but then just locks up when loading and I am left with a white screen. Doesn't matter which browser I try it in.

Share this post


Link to post
Share on other sites

Same issues here. It's annoying as my business email address is a hotmail one and I haven't been able to get in for 2 days. It logs me in but then just locks up when loading and I am left with a white screen. Doesn't matter which browser I try it in.

I get the same but do a refresh, get the "Resend" message, then it makes me put my password in again. After three or four goes I usually get in.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

  • 259 Brexit, House prices and Summer 2020

    1. 1. Including the effects Brexit, where do you think average UK house prices will be relative to now in June 2020?


      • down 5% +
      • down 2.5%
      • Even
      • up 2.5%
      • up 5%



×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.