Jump to content
House Price Crash Forum

Archived

This topic is now archived and is closed to further replies.

The Ayatollah Buggeri

Right Click - Run As Administrator In Windows 7 X64

Recommended Posts

Like it says in the title. When I right click on a program icon in the start menu (while logged on as a restricted user, obviously), the 'run as administrator' option simply isn't there. My machine has four OS partitions (XP x64, Vista x86, 7 x64 and Ubuntu x64), and on all the other Windows installations that option is present and correct. I've tried Googling and found several suggested solutions for when the option does appear but selecting it doesn't work (i.e. you select R as A, enter the administrator password and then nothing happens), but nothing for suggesting a response to that option simply not being there on the menu.

It's a minor annoyance - I only need to run one program regularly on the 7 installation that needs elevated privileges - but nevertheless I'd be intrigued if anyone has any suggestions. I'm guessing the solution lies in some sort of registry tweak. Ta in advance!

Share this post


Link to post
Share on other sites

net user administrator /active:yes

I've got win 7 64 bit and it's on mine. There's a wee shield with it. Something in ctrl panel security ctr? Dunno.

Workaround if it's just one program would be to use the runas command in a batch file?

Share this post


Link to post
Share on other sites

It's because you're looking at a shortcut to the program when looking in that start menu bit sometimes.

Go through explorer to the program files/etc folder and do the right click there on the program exe file itself.

Caught me out as well!

Share this post


Link to post
Share on other sites

No luck with net user administrator.

As TFH said, it's just the right-clicking from the shortcuts in the start menu that won't work. Going to the executable itself will, but doing so is a bit of a faff.

Thanks for the tips, folks.

Share this post


Link to post
Share on other sites

You could try Properties->Shortcut->Advanced->Run as Administrator. I believe this forces the shortcut to always run with Admin privileges. If that's not what you want, apparently pressing Ctrl-Shift while executing the shortcut elevates its privileges.

Oddly enough, all my shortcuts seem to have the "Run As..." context menu.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

  • 259 Brexit, House prices and Summer 2020

    1. 1. Including the effects Brexit, where do you think average UK house prices will be relative to now in June 2020?


      • down 5% +
      • down 2.5%
      • Even
      • up 2.5%
      • up 5%



×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.